Back to overview
Downtime
Test incident 2
Sep 10, 2023 at 6:11pm UTC
Resolved
Sep 22, 2023 at 8:14pm UTC
It's alright now
Affected services
Updated
Sep 22, 2023 at 8:13pm UTC
Yo thhi si s bad
Affected services
Created
Sep 10, 2023 at 6:11pm UTC
Testing again
Affected services